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Guia de Utilização do PSpice 

 

1. Introdução 

O programa SPICE é um simulador de circuitos direccionado para o projecto de circuitos 

electrónicos. SPICE é o acrónimo de “Simulation Program with Integrated Circuits 

Emphasis” (Programa de Simulação com Ênfase em Circuitos Integrados). 

O programa SPICE, na sua primeira versão, foi apresentado por Laurence W. Nagel na 

sua tese de doutoramento na Universidade da Califórnia em Berkeley em 1972. Inicialmente 

escrito na linguagem Fortran, este programa passou seguidamente a ser codificado em 

linguagem C. Trata-se de um programa aberto, bem documentado, continuamente actualizado 

pela Univesidade de Berkeley e de utilização universal. A sua popularidade extravasou 

largamente os meios académicos para servir de ponto de partida ao desenvolvimento de 

muitos programas comerciais virados para o projecto automático de circuitos electrónicos 

(EDA-Electronic Design Automation), tanto na área da microelectrónica como também no 

campo do projecto de circuitos impressos (PCB-Printed Circuits Board). O programa OrCAD 

(Oregon Circuit Aid Design) é um desses exemplos. A correspondente versão demo mais 

actualizada pode ser descarregada através da Web a partir do sítio da empresa Cadence actual 

proprietária do programa. Esta mesma empresa dispõe de outras ferramentas de software 

viradas exclusivamente para a construção de circuitos integrados, mas funcionando em 

ambiente Unix, ao passo que o programa OrCAD/PSpice funciona em ambiente Windows.  

 Mais que um programa, o OrCAD é uma plataforma de trabalho que integra uma 

família de ferramentas de software com o objectivo de assistir ao projecto de circuitos 

impressos desde a fase do desenho do esquema eléctrico até ao “layout”. O programa PSPICE 

AD (analógico-digital) é o simulador de circuitos dessa plataforma. Este programa foi criado 

em 1985 pela empresa MicroSim para adaptar, de forma optimizada, o programa Spice aos 

computadores pessoais IBM compatíveis que então surgiam. A grande inovação então 

introduzida foi o programa PROBE que permitia a visualização gráfica dos resultados da 

simulação. Contudo, em si mesmo, a principal limitação do programa resultava do facto da 

introdução de dados do circuito (netlist) e de comandos ser unicamente possível através de 

ficheiros de texto com extensão *.cir. O editor de esquemas eléctricos, Schematic, vem 

ultrapassar este problema. De dentro desse editor e sem abandonar o modo gráfico, o PSPICE 

AD pode automáticamente ser iniciado e correr com base na netlist contida no ficheiro *.cir 

também criado previamente de modo automático. A aplicação Capture permite criar um 

ambiente gráfico onde, entre outras, estas três aplicações se integram. No entanto, quando o 
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objectivo é apenas a simulação de circuitos eléctricos, uma versão simplificada do programa 

CAPTURE, denominada Schematics criada pela MicroSim será provavelmente a mais 

adequada. Para além da edição de esquemas esta aplicação apresenta a vantagem suplementar 

de permitir editar, modificar e criar a sua própria biblioteca de símbolos. Esta aplicação veio 

incluída na versão OrCAD 9.1, cuja versão demo é denominada PSPICE Student e que pode 

ser descarregado através do Fénix a partir da página da disciplina ou de qualquer outro sítio 

da Web. Esta é a única versão DEMO da OrCAD/CADENCE que permite a edição e criação 

de símbolos com mais de dois terminais. Será este o programa de simulação de circuitos que 

utilizaremos nesta cadeira. No decurso da correspondente instalação não se esqueça de activar 

a opção Schematics. 

 
2. Desenho do esquema eléctrico a simular 
 

Crie uma pasta em C:\  para as suas simulações com o PSPICE. Note que o PSPICE 

não reconhece as pastas em directorias com caminhos de acesso complexos com mais de 

quatro níveis hierárquicos. Em seguida abra o programa Schematics como a seguir se indica, 

Fig.1. 

 

 
 

Fig.1 

 

Abrir-se-á de imediato a página 1 do esquema com o título Schematic1, Fig.2. 
 

 
 

Fig.2 
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Active o menu File>Save As… do editor de esquemas, Fig.2, e salve para a pasta que 

criou este ficheiro com um novo título à sua escolha. Sobre esta página do esquema e 

cumprindo as etapas a seguir indicadas deverá desenhar os dois circuitos que se apresentam, 

Fig.3. 

 
Fig.3 

 
2.1 Seleccionar e colocar os símbolos dos elementos dos circuitos  
 

 Comece por activar o botão “Get New Part”  da barra de ferramentas de forma a 

surgir a caixa “Part Browser Advanced” indicada na Fig.4. Procure o gerador de tensão 

alternada sinusoidal e, depois de activar o botão “Place”, coloque sobre a página do esquema 

dois destes geradores. 

 

Fig.4 
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Qualquer elemento pode ser colocado sobre a página as vezes que se queira premindo 

para tal, de cada vez, o botão esquerdo do rato. Esse elemento deixará de ser seleccionado se 

o botão direito for pressionado ou, em alternativa, carregar na tecla Esc. 

Seguidamente seleccione e coloque sobre a página os restantes elementos do circuito, as 

resistências R, o díodo D1N4002 e os terminais do potencial de referência, GND_EARTH ou 

GND_ANALOG. Depois de fechar a caixa de diálogo disponha os elementos como indica a 

figura 3. Cada um dos elementos pode ser arrastado, rodado e copiado desde que este 

previamente tenha sido seleccionado com o ponteiro do rato pressionando o botão esquerdo. 

Se não houver outra indicação, o lado esquerdo de cada elemento representará o nó + e o 

direito o nó -. Qualquer que seja o elemento, o PSPICE utiliza a convenção na qual são 

arbitradas como positivas a corrente e a tensão do nó + para o nó – (dispositivos receptores). 

Para rodar um elemento no sentido directo poderá utilizar as teclas Ctrl-R. Para que um 

elemento seja disposto verticalmente com o nó + na parte superior deverá utilizar as teclas 

Ctrl-R três vezes consecutivas.  

 

2.2 Desenho de ligações  
 
 O passo a seguir é a ligação entre os diversos elementos. Para tal active o botão “Draw 

wire”   da barra de ferramentas. Marque o ponto inicial com o ponteiro do lápis  premindo 

o botão esquerdo do rato, e, em seguida, marque o ponto final da ligação do mesmo modo. A 

ligação surgirá automáticamente desenhada no esquema. Para deixar de seleccionar o modo 

“Draw wire” basta pressionar o botão direito do rato ou a tecla Esc.  

Uma vez realizadas as ligações, prima duas vezes consecutivas o botão esquerdo do 

rato sobre cada uma destas ligações. Abrir-se-á de cada vez a caixa de diálogo “LABELS” 

que permite atribuir os rótulos a, b e c a cada uma das ligações do circuito. Em seguida, 

coloque os marcadores do nível de tensão   para a medida do potencial em cada ligação. 

Eventualmente, caso queira colocar sobre a página do esquema qualquer comentário 

ou desenho pode utilizar a barra de ferramentas de desenho colocada no lado esquerdo do 

editor de esquemas, Fig.2. 

 

2.3 Atribuição de valores e alteração de designações  
 

Para alterar valores ou mudar designações terá que começar por apontar estes atributos 

dos elementos com o ponteiro do rato e pressionando duas vezes consecutivas o botão 

esquerdo. Altere o valor de R1 para 100�. Seleccione da mesma forma, com o botão esquerdo 
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do rato, o gerador V1. Na caixa de diálogo em seguida aberta atribua os valores VOFF=0, 

VAMPL=5V e FREQ=50Hz e faça OK. De modo análogo faça o mesmo para o gerador V2. 

 

3. Simulação  
 
3.1 Análise de resposta no domínio do tempo  
 

3.1.a Especificações para a análise temporal 

Seleccione o botão “Analysis Setup” , active a análise Transient e abra a respectiva 

caixa de diálogo como mostra a Fig.5. Escolha como “Final Time” 60ms e como passo 

máximo, Step Ceiling=10u (10�s). Active o botão “simulate”  da barra de ferramentas. 

 

 

Fig.5 

 

Verificará de imediato que o programa ORCAD PSPICE AD DEMO começara a ser 

executado ao abrirem-se as três janelas do respectivo editor como mostra a Fig.6. Após a 

indicação, na janela de saída, do fim da execução da simulação, surge na janela de trabalho a 

janela do programa PROBE com a representação da evolução temporal dos potenciais nos 

conductores a, b e c. Para melhor visualização destes gráficos convirá activar o ícone 

“Alternate Display”  para apenas deixar aberta a janela de trabalho e ver surgir as 

restantes barras de ferramentas associadas ao programa PROBE e ao programa CURSOR. 
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Fig.6 

3.1.b Observação de resultados 

Active o botão “Toggle Cursor” , ou, em alternativa entre no menu 

Trace>Cursor>Display do programa PROBE. Abrir-se-á a janela “Probe Cursor”, como 

mostra a Fig.7, com o cursor A1 associado ao botão esquerdo do rato e o cursor A2 ao botão 

direito. Pressionando com o botão esquerdo sobre a legenda  e activando o botão 

, ou, em alternativa entrando em Trace>Cursor>Max, poderá ler na janela do Cursor o 

valor máximo de Va detectado pelo cursor A1 bem como o instante que lhe corresponde. Para 

associar o cursor A2 à onda Vb terá que pressionar o botão direito do rato sobre a legenda 

. Mantendo o botão direito pressionado, arraste o cursor A2 para poder medir o valor 

de Vb correspondente ao mesmo instante. Na janela do Cursor leia o valor da diferença Va-

Vb para esse instante. 

 

 
Fig.7 

Janela de saída Janela de estado da simulação 

Janela de trabalho 
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3.1.c Registo e análise de resultados 

Registe os valores das tensões aos terminais da resistência R1 e díodo D1 para os 

instantes em que Va atinge, respectivamente, um máximo e um mínimo. Obtenha uma cópia 

do gráfico observado entrando no menu Window>Copy to clipboard activando a opção de 

fundo transparente e colando-o na folha de registos. 

3.1.d Representação do esquema eléctrico na forma Excitação/Circuito 

 Para simplificar o desenho e a análise de circuitos, por vezes distribuídos em várias 

páginas dum mesmo esquema, é usual separá-los da correspondente excitação. Para tal, active 

o ícone “Get New Part”, seleccione três portos do tipo BUBBLE (outros tipos de portos como 

OFFPAGE e GLOBAL podem também ser utilizados) coloque-os sobre a página do esquema 

eléctrico do circuito que construíu. Depois de seleccionar cada um dos conectores com o 

botão esquerdo do rato, atribua-lhes o rótulo (LABEL) “VIN” e disponha o circuito como a 

Fig.8 indica. Active o botão “simulate”  e verifique que os resultados anteriores da 

simulação não são alterados.  

 Feche o programa OrCAD/PSPICE AD Demo e volte ao Programa Schematics. 

 

 
Fig. 8 

 

3. 2 Função de transferência para um varrimento em tensão contínua 
 

3.2.a Especificações para o varrimento em tensão contínua 

Active o ícone “Get New Part”, do programa Schematics e seleccione um gerador 

VDC, um conector BUBBLE e uma tensão de referência GND_EARTH e coloque-os sobre a 

página do esquema eléctrico conforme a Fig.9. Note que o porto “VIN” deverá estar agora 

ligado ao gerador de tensão V3. Modifique o rótulo do conector ligado a V1 para “VOFF”. 
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Com este artifício o gerador V1 e respectivo conector poderão ainda ser mantidos no esquema 

na eventualidade de se pretender repetir o estudo da evolução no tempo.  

 

Fig.9 

Seleccione o ícone “Analysis Setup”, active a análise DC Sweep e desactive as 

restantes, e, conforme se indica na Fig.10, introduza o nome da variável de entrada que 

pretende fazer variar, o intervalo e o passo da respectiva variação. 

 

Fig.10 

3.2.b Extracção e análise de resultados 

Active o botão “simulate” . Observe, dentro da janela do programa Probe, os 

gráficos obtidos para Va, Vb e Vc notando que para este último caso o andamento não é linear 

com V3. Caso pretenda ver a diferença de potencial entre os pontos a e c, entre no menu 
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Markers>Marker Voltage Diferential e com o botão esquerdo do rato seleccione os nós a e 

c.  

Obtenha uma cópia do gráfico observado e registe, respectivamente para V3=+5 , os 

valores assumidos por Vc e pela tensão aos terminais do díodo, Vac.  

 

3.3 Estudo da polarização do circuito em corrente contínua  
  

3.3.a Especificações para polarização do circuito 

Seleccione o gerador V3 pressionando sobre ele duas vezes consecutivas o botão 

esquerdo do rato e atribua-lhe o valor DC igual a 5V. Active o botão “Analysis Setup”  e 

verifique se a opção “Bias Point Detail ” se encontra seleccionada e as restantes desactivadas. 

Active na barra de ferramentas os botões “Enable bias voltage display” e “Enable bias 

current display”  e em seguida o botão “simulate” .  

3.3.b Registo de valores 

Após completar a simulação, abra o ficheiro de texto de saída do programa OrCAD 

PSPICE AD DEMO recorrendo ao menu View>Output File. Na parte final desse ficheiro 

leia e registe os valores de ID e VD que definem o ponto de funcionamento em repouso (PFR) 

do díodo bem como os valores referentes aos parâmetros do respectivo modelo incremental, 

resistência equivalente, REQ, e capacidade, (CAP).  

Feche o programa PSPICE AD e leia, os valores Va, Vb e Vc escritos por este 

programa sobre a página do esquema eléctrico do editor de esquemas SCHEMATICS.  

Modifique V3 para -5V e repita os procedimentos anteriormente tomados para 

V3=5V. 

3.3.c Efeito da temperatura no ponto de funcionamento em repouso do díodo  

Para a polarização V3=5V, active o ícone “Analysis Setup”  bem como a caixa de 

diálogo “Temperature” e modifique o valor de defeito 27ºC (300K) para 100ºC, Fig.11. Inicie 

a simulação com o botão “Simulate” . Determine o novo ponto de funcionamento em 

repouso ID e VD do díodo. Active de novo o ícone “Analysis Setup” e desactive a opção 

temperatura para regressar ao valor de defeito 27ºC. 
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Fig.11 

 

3.3.d Efeito dos parâmetros do modelo do díodo no seu PFR  

Depois de seleccionar o díodo D1 pressionando apenas uma vez o botão esquerdo do 

rato, entre em Edit>Model… e sobre a respectiva caixa de diálogo seleccione o botão “Edit 

Instance Model (Text)”, Fig.12. Dentro do editor de modelos modifique o parâmetro 

IS=14.11E-9 para IS=14.11E-6 e faça OK. Inicie a simulação com o botão “Simulate” e 

determine e registe o novo ponto de funcionamento em repouso ID e VD do díodo que 

corresponde ao novo modelo de díodo que criou.  

Volte de novo a editar o modelo do díodo e reponha o valor anterior de IS.  

 

Fig.12 

 

Nota: O PSPICE possibilita tanto a criação de novos modelos de dispositivos eléctricos como a alteração 

dos modelos que constam nas bibliotecas de validade global eval.lib e breakout.lib incluídas na biblioteca 

de defeito ….OrCAD_Demo\Capture\Library\Pspice\NOM.LIB. Contudo as alterações a serem realizadas 

não alteram o conteúdo destas bibliotecas. Os modelos modificados terão uma validade local e farão parte 

duma biblioteca que de modo automático surgirá na pasta que criou no início da sessão de trabalho. O 
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PSPICE dará indicação de erro se não conseguir localizar as bibliotecas correspondentes aos dispositivos 

do esquema. Caso necessite de corrigir essa situação deverá entrar em Analysis>Library and include Files 

e atribuir o caminho adequado para aquelas bibliotecas. 

 

3.4 Regime incremental: análise da resposta em frequência  

 

3.4.a Especificações para a polarização do circuito 

Active o ícone “Get New Part”, seleccione o gerador VAC e coloque-o em série com 

o gerador V3, Fig.13. Premindo duas vezes consecutivas sobre a designação desse gerador 

atribua-lhe o rótulo V4 caso essa designação não lhe seja atribuída por defeito. Altere para 

10mV a amplitude de tensão desse gerador. O gerador VAC (V4) servirá para estudar o 

comportamento do circuito em regime incremental para a situação em que a perturbação 

introduzida, do tipo sinusoidal, não modifica significativamente as condições da anterior 

análise em corrente contínua e, em particular, os valores dos parâmetros do modelo 

incremental do diodo D1. 

 

Fig.13 

 

Seleccione o ícone “Analysis Setup”, active a análise AC Sweep e abra a respectiva 

caixa de diálogo. Escolha a opção que lhe permite analisar o comportamento do circuito 

quando o sinal sinusoidal do gerador V4, com a amplitude 10mV, apresenta uma frequência 

que pode variar de década em década, começando em 10Hz e terminando em 100MHz, 

Fig.14. 
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Fig.14 

3.4.b Registo de valores 

Active o botão “Simulate”  e, em seguida, dentro do PSPICE AD, active o botão 

“Toggle Cursor” , ou, em alternativa, entre no menu Trace>Cursor>Display. Com o 

botão esquerdo do rato seleccione Va . Arraste o cursor A1 para ler a amplitude de 

Va para a frequência 1KHz. Para a mesma frequência leia as amplitudes de Vb e Vc depois de 

as seleccionar com o botão esquerdo do rato e verifique que esses valores satisfazem as 

relações  

32

1 2 3
b a c a

EQ

RR
V V V V

R R R R
= =

+ +

 

 

Para a obtenção dos gráficos das fases de Va, Vb e Vc na mesma página que contém os 

andamentos para as amplitudes, active Plot>Add Plot to Window e entre em Trace>Add 

Traces e no campo Trace expression escreva P(V(a)), P(V(b)), P(V(c)) e faça OK. Conclua 

sobre a evolução da amplitude e fase de Vc quando a frequência tende para infinito. 

Caso queira obter separadamente um gráfico para os andamentos das fases das tensões 

entre no menu MARKERS>Mark Advanced e seleccione vphase e depois OK. Coloque os 

novos marcadores sobre os ramos a b e c do esquema e remova os marcadores de tensão 

Voltage Markers. 
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